FrameXML.Editor not loading

Jun 23, 2010 at 5:06 AM
Edited Jun 23, 2010 at 5:23 AM

I have been through these discussions and found multiple unanswered posts regarding this error.  On my Win 7 64-bit system I have repeatedly installed/uninstalled AddOn Studio to different locations and tried running it with different options, admin rights, and so forth.  No design view.  What is odd is that the very first time I installed it I did get Design view but nothing in the Toolbox.  After I started messing with it I lost Design view.  This package looks to have potential but not if I am unable to get all the features to work.  I just spent an entire evening futzing with this.  Can anyone please help?

Jun 24, 2010 at 2:24 PM

I am having the same problem, yet before I can even get to the part where is shows Frame.xml, I get an error:

Package Load Failure

Package

'Microsoft.WowAddonStudio.FrameXml.Editor.FrameXmlEditorPackage, FrameXml.Editor, Version=2.0.40211.1, Culture=neutral, PublicKeyToken=652b006182260a0a' has failed to load properly ( GUID = {C20A7700-F178-4AE1B58A-AA5EC4DABBF6}). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'appenv /resetskippkgs' to re-enable package loading.

[Yes] [No]

 

I press No, and I can't see the screenshot like you have on your front page, instead writing.

Jun 25, 2010 at 1:28 PM
Edited Jun 25, 2010 at 7:58 PM

I have the same issue that Tyseno has.

 

Win7 32-bit, Visual Studio 2008 SDK 1.1

Visual Studio 2008 SP1 is on this machine as well.

 

I'm going to try installing the 1.0 SDK instead to see if that helps.  Probably not...  Edit: Did nothing.

 

Jun 26, 2010 at 5:01 PM

I'm having the same problem.  Appears to have started after the 3.3.5 patch.  However, there were also some MS patches that installed during the same time as the 3.3.5 patch.

Here are the MS Patches installed this week.  Next step is to remove each one and see if it is causing the problem.

- Cumulative Update for Media Center for Windows Vista for x64-based Systems (KB982480)
- Microsoft .NET Framework 3.5 SP1, Windows Vista SP2, and Windows Server 2008 SP2 Update for x64-based Systems (KB982525)
- Update for Windows Vista for x64-based Systems (KB982519)

 

Jun 28, 2010 at 11:45 PM

coomacheek,

Those MS patches have no bearing on the application.  They have been around long before this application was released.  Also, it is not related to the 3.3.5 patch.  I had this issue before the patch hit.  

The issues lies with an "error" or "bug" in the assembly that defines the XML editor.

Jun 30, 2010 at 3:23 AM

This is very odd because the FrameXML file is there and is the correct version, it just does not load for some reason.  I uninstalled AddOn Studio, restarted, scrubbed the registry of any references to it, restarted, then reinstalled AddOn Studio.  No change.  Looks like it's Notepad++ FTW.

 

Jun 30, 2010 at 7:06 AM
Windows 7 Ultimate (x64), Visual Studio 2008 SDK1.1 SP1 installed I am having the same problem. When creating a new project I cannot view anything in design mode. I can only view the code for forms. Installed AddOn Studio and then uninstalled/reinstalled. Same problem. Does anyone have a fix for this problem? I would love to actually be able to start the tutorials.
Jul 2, 2010 at 9:36 AM

Windows XP Home, Service Pack 3, Visual Studio 2008

I was getting the weird XML error too but I also uninstalled half a dozen things on my comp that day, including the needed C+ Redistribute files and .NET Framework 4.0. (Which also messed up a load of things on my comp). I've redownloaded the .NET Framework 4.0 and reinstalled Addon Studio Beta v2 and everything works now except for the design view. I can create and edit projects but I just can't get the damn design view up >.< No idea whats going on, no error messages, installation went fine but no dice.

Jul 11, 2010 at 10:21 AM

I am in a panic. Does anyone solved this problem?

Jul 11, 2010 at 8:58 PM

I'm having the same issue with windows 7 x64 version, I installed it fine and then the error popped up [See Tyseno] and I clicked yes. The tutorials doesn't even show XML theres no tools and I cant view my addons XML I like the way this tool looks, and I'd like to get it working on my comp as well please help.

Coordinator
Jul 16, 2010 at 11:52 PM

Hey folks,

I know that many of you have been frustrated with the installation experience and the issues with the designer. We just published a new wiki page that goes into what we're going to be doing with AddOn Studio going forward.

I hope this helps,

Dan
Project Coordinator 

 

Jul 21, 2010 at 12:57 PM
Edited Jul 21, 2010 at 1:38 PM
Someone may have found a solution (or at least a root cause of the issue). See the link below. http://forums.worldofwarcraft.com/thread.html?sid=1&topicId=26227632927
Aug 5, 2010 at 9:33 AM

Hallo,

please, is here any solution?

Sep 12, 2010 at 12:17 PM

I fixed the problem!

wowpath variable problem: I had the same problems: First of all it couldn't find my wowpath variable cause I copied the game on the computer without installing it. After an hour of frustration I installed the game the official way and after that the wowpath variable problem was fixed, BUT a new problem was born: there was no longer a design view interface and no toolbox.

design view / toolbox problem: After hours of frustration (reinstalling, trying the 1.0 version, etc. etc.) I suddenly realized some message I got earlyer when wowaddon studio asked me to disable some module or object in future and I might have said yes during my frustrated messing around. I thought something on my disk or in my registry must be configured in a way it disables a needed module. Uninstalling doesn't clear these temp / configuration files. So what I did was I uninstalled Wow Addon Studio plus all the Visual Studio crap. Then I downloaded a decent Search tool 'cause under Windows 7 (and probebly Vista too), searching for hidden files in your C:\Documents and settings and C:\Users is kind of impossible. I deleted all files with "wow addon", "wowaddon" and "visual studio" in it. Then I cleaned my registry and searched for the same stuff. This is a real pain, cause you need to delete A LOT of mess for the Visual Studio crap. Also be careful cause you don't want to accidently delete .NET stuff and Microsoft Office stuff. After that, I had put the power cable out of my computer for a couple of minute, in order to clear the RAM memory. Then I reinstalled Wow Addon Studio and what do you know, I got Design View and a Toolbox!

Kneel for me please.... Thank you. Have fun...

Sep 17, 2010 at 10:07 PM

The error is associated with a XML syntax error which is embedded in the core MPQ files.  The syntax error has been corrected in v4.0 of the wow client, so unless you're in the beta you'll have to wait for Cataclysm.

I am part of the Cataclysm beta program and no longer have the issue with the frame editor.  In order to work around it, I had to update the "GamePath" registry value to point to my beta install folder.  Once I did that, Addon Studio then referenced the beta MPQ files. 

For me the registry key was located under:

HKLM\Software\Wow6432Node\Blizzard Entertainment\World of Warcraft\

Sep 21, 2010 at 6:06 PM
Edited Sep 21, 2010 at 6:40 PM

So how do you 'point' Wow Addon Studio to a different WoW install? I have 4.0 on my machine, (the typo above is fixed in 4.0) but I don't know how to make Wow Addon Studio use that installation path.

UPDATE: nvm.  I edited the registry with the 4.0 path and now i get no errors. However, I still have NO design view.

Someone wanna tell me what the crap "You may use 'appenv /resetskippkgs' to re-enable package loading." means?  Where the hell do you type that in at to re-enable the Design package?

Also, I have the full version of Visual Studio 2008, 1.1 SP1, but WoW Visual Studio isn't using it, its using the express version that it apparently installed itself.  Anyway to correct that?

Oct 25, 2010 at 3:01 PM

I just posted a Threat Last Friday. Concerning #Develop. It will share what I have come up with... An !Idea/Suggestion! on a Plausible soloution. Yet it needs work.

Mar 19, 2011 at 7:44 PM
Edited Mar 19, 2011 at 8:17 PM

The post about there being a mistake in one of the xml files buried in the mpq's after 3.3.5 is correct.  That effectivly crashes XMLFrame component.  One of the files has "middle" for a virtical alignment ithink, and that causes the parse in XMLFrame component to throw an unhandled exception which bubbles up and causes the VS package loader to "fail" the whole package, propting you to see if you want to stop showing the fail message.  If you choose to stop showing the message it will effectivly stop trying to load the package, and you will have no XMLFrame component and thus no graphical editing of the frame xmls files, permanently, sort of, even if you start using the blizzard toolkit files afterward, which would otherwise let the XMLFrame component "pass" the loading stage.

This can be fixed a little more easily than manually clearing the registry, to get you back to zero.  For v1 and v2 you need to run the application with: /setup /resetskippkgs which will both force the XMLFrame package to be installed, sortof, and reset the list of skipped packages to load. You can also run with /resetuserdata which will clear your tool and menu cache, among other things, and allow those to be built again.  These options will let you reset areas of the registry and other files that are not in the main application setting inthe registry and not in your "my documents" wowaddonstudio set of files.  The installer for v1 and v2 does not do the best job of handlign this for you. Which is why you end up basically "scr*wed" for a while no matter what you do.  These are the options the VS devs hit a lot when working on VS.

As far as using a different location for WoW, this works.  The problem is that you need to tell the dialog that pops up that you want to keep seeing the messages, then go change the location to point to the toolkit in the AddOn studio settings in Options in the application, or you need to "dope" your wowfiles wiht the toolkit correctly before you launch aoswow.  If you point aswow to another folder you wil not be able "deploy" to wow anymore by using build in aswow, the built addon wil get deployed to the tookit folders.  If you dirty your wow install you wil have other issues.  The blizzard "addons" int eh addon folders are jmsut placeholders now, with a stub file.  After you copy the toolkit over your interface folders, you will need to delete the blizzard ui "addons" so they grow back when you start wow without the junk in them. 

 

There are other issues caused by v1 and v2 that can cause wow application issues, which blizzard has mostly dealt with though it wasnt done because of aswow.  aswow will load mpq files with read/write and only share for read, and leaves the files open for the duration which effectivly locks wow from its own files with current versions. This used to cause issues on some versions of wow, where the updater would fail in odd ways leaving you in a bad state.  Currently the updater will fail on the wow loader gracefully, if it cant open the files before the patch process starts.  But you won't be able to start wow as long as aswow is up. Currently this is unlikely in that aswow, as of cataclysm, dosn't look for all of the right files, and is a non-issue except that aswow wont load the XMLFrame component.

Ther is another version while these guys are away where all of these issues were solved, and correctly and safly reads game content: http://www.wowwiki.com/AddOn_Studio_2010

In this version there is an extra option as well, though not necessary for it work correctly, where you can specify an alternate location for toolkit files, apart form the wow install location, if you wish for soem reason to use the blizzard supplied unpacked set of files supplied in the toolkit itself, which is baqsssically what they are.  You dont need the toolkit or the alternate location to use this version of addon studio.  You can use this however to both use the tolkit files or to add any additional support files you wish, including any production content, just like Blizzard does without having to compile the MPQs.   :)