2.0 Beta: Visual Designer trouble.

Jul 31, 2008 at 5:03 AM
Edited Aug 1, 2008 at 1:24 AM

Biggest user error ever most likely.

It gave me an error regarding not being able to load a package and a GUID number,(and a command to reset package i of course paid no attention to at all before i clicked it off) so i of course told it to not load it.

Get into trying to test the new pretty things out and..No Visual XML Desginer, yes i have the Text/Code XML window but no graphical element to it and for the life of me cannot find how to show it.

So i ask ye mystical wizards of Addon Studio how doth i fix mine user error?

edit - Okay the command in question was devenv /resetskippkgs but i am not quite sure how to do that from the shell enviroment (i only have VS 2005 installed and i know its not cross compatible)
eidt2-and i just did it by the long way through the cmd line(navigteing to the folder) and still nada...hmm*gets her poking stick*

Edit3- Exact error(will also post to issue track):  AddOn Studio for World of Warcraft
 ---------------------------
 Package Load Failure
 
 Package 'Microsoft.WowAddonStudio.FrameXml.FrameXmlEditorPackage, FrameXmlEditor, Version=1.0.30107.1, Culture=neutral, PublicKeyToken=3f65cf85c2f22261' has failed to load properly ( GUID = {C20A7700-F178-4AE1-B58A-AA5EC4DABBF6} ). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'appenv /resetskippkgs' to re-enable package loading.
 ---------------------------
 Yes   No   
 ---------------------------
Aug 3, 2008 at 10:14 PM
Edited Aug 3, 2008 at 10:21 PM
I am having the same issue. :(

*Update*

I got it fixed.   What you need to do is uninstall the older version and the new version you just installed.  I had to use AusLogics Uninstaller to do it properly.  Then just reinstall the new version like normal and it worked flawlessly.
Aug 3, 2008 at 11:29 PM
Edited Aug 4, 2008 at 12:04 AM
somewhere in the back of my head i kept thinking that might be it...but i don't listen to that part of my head.

Anyway trying that now. should work.

*update* getting this now
http://www.codeplex.com/WarcraftAddOnStudio/WorkItem/View.aspx?WorkItemId=2516


Thank you for help though/
Aug 27, 2008 at 5:31 AM
Don't mean to bump but has anyone fixed it yet in some manner (i have tried uninstalling about alot...then reinstallihng..and registry trawling).

And any ETA on maybe a bug fix patch? Know you guys are bound to be busy over there but just curious.