Anyone found a solution for the squish.dll bug?

Oct 5, 2008 at 7:02 AM
I've tried manually registering the DLL, tried uninstalling (cleaning the registry as well), and reinstalling, reinstalled the resouce kit from Blizz, re-extracted the UI.xsd file. and no matter what I do. V2 simply bows up with an unhandled excpetion involving squish.dll

OS particulars:

WinXP Pro
32 Bit
V2002 SP3

Anyone found a good answer, or did everyone just give up?


Oct 6, 2008 at 6:52 PM
Edited Oct 6, 2008 at 7:02 PM
I fixed it on my computer and I think this was what finally did it.

Uninstall Addon Studio.
Install Visual Studio C++ express from Here. http://www.microsoft.com/express/vc/
Reinstall Addon Studio

Hope this helps.
Oct 25, 2008 at 12:46 AM
No solution for me.
http://www.microsoft.com/express/vc/   - after download visual C++ setup and updating installer and I don't know what else, endless installing/download
and reinstall Addon Studio,
it's all the same - Error ... squish.dll ...

Addon Studio does not work anyway.
I think I delete the whole thing and forget it. Possibly there might be a working Version in some years.



Oct 28, 2008 at 12:00 PM
Edited Oct 29, 2008 at 2:27 PM

Here is the problem:

Squish.dll was deployed in the Debug build, not Release one, and moreover, it was compiled to use Debug DLL libraries instead of static linked Debug ("Code Generation" property in project's properties). So as long as you don't have access to Microsoft_VC90_DebugCRT_x86_x64.msm merge module (maybe having just extracted libraries will be enough, I don't know) and don't find a way to install them on your system (which is not trivial), you won't be able to run the Addon Studio properly. And since there are debug modules not meant for redistribution, there is no legal way to get them unless you get Visual Studio 2008 (and free Express versions won't do the trick, I'm afraid), sorry :(

You may find some information on this here: http://msdn.microsoft.com/en-us/library/aa985618.aspx

EDIT: You're looking for Microsoft_VC90_DebugCRT_x86.msm file, previously mentioned _x86_x64.msm file is for 64bit programs and won't do any good here besides giving you headache when you'll waste few hours trying to diagnose "Why the hell it isn't working". Today I'm gonna try the good old 32bit version and I'll give some report here on my progress. But still, the perfect solution is rebuilding Addon Studio (and especially squish.dll) in Release configuration. Hey Author, can we count on it? :)

Nov 20, 2008 at 9:47 PM
Hi Guys, you may wanna install the NVIDIA Texture Tools 2 which includes the squish libraries.
I installed the NVIDIA tools first then the Addon studio and it worked just fine!

http://developer.download.nvidia.com/tools/texturetools2/NVIDIA_Texture_Tools_2.04.1016.0025.exe

From
http://developer.nvidia.com/object/texture_tools.html

Here are a few references as well
http://code.google.com/p/libsquish/
http://code.google.com/p/nvidia-texture-tools/
Coordinator
Feb 15, 2009 at 9:02 PM
Can you try installing AddOn Studio version 2, Beta 2, Release ID: 22870? This should fix the Squish DLL hell issue.

Link: http://www.codeplex.com/AddOnStudio/Release/ProjectReleases.aspx?ReleaseId=22870