Problem installing Net. Framework 3.5

Dec 18, 2008 at 1:58 AM
I recently tried to install addon studio, but i need Net. Framework 3.5 my only problem is it refuses to allow me to install net. 3.5
The installer failed to install, just throwing me a failure error message.
When i went to the microsoft download site it refuses to download the file and just throws me a error when the webpage loading that says "cant conenct to page.
I wanna try addon studio but i just cant seem to be able to get Net. Frame 3.5 to install. ive looked aroudn but to no avail. Can anyone help em with my problem installing Net. Framework 3.5
Im not sure if its a problem with a firewall, or w/e but i cant seem to figure out the problem no matter what i do.
Feb 15, 2009 at 9:03 PM
Can you try installing the new release AddOn Studio version 2, Beta 2, Release ID: 22870? This should fix the issue

Link: http://www.codeplex.com/AddOnStudio/Release/ProjectReleases.aspx?ReleaseId=22870
 
Feb 16, 2009 at 2:08 AM
Well i really would like to try this, but im still having problems.
Upon downloading from the link i ran setup.exe
It looks like its trying to install Microsoft Visual Studio 2008 Shell SP1 (Isolated Mode), but then fails near the end of the installation.
I tried the AddonStudio.msi file but that failed too
I still dont have the most up to date .Net Framework but i cannot download it.
Upon going to the official website from microsoft when i click download IE just says "Could not open page"
I managed to get the installer of another site, but upon installation it just says 
Status: Attempting to establish connection to server ( # of 5 )

Feb 16, 2009 at 5:47 PM

Hey man, just to be clear, did you try running the Visual Studio Shell installer (link below)?

If so, and that failed, what is the exact error message it gave you?
Also, what operating system are you running?

Can you open up Internet Explorer and type in the url box: javascript:alert(navigator.userAgent) and copy/paste the text? This will let us know what version of the .NET Framework you're running.

Thanks,
-Dan 

Feb 16, 2009 at 7:16 PM
Using the provided link i get the error
The installation failed with the following message:
Fatal Error During installation

Viewing the log file gives me this
Exe (d:\745d85f9f78b7b1f29cb955026\dotNetFx35setup.exe) failed with 0x80070643 - Fatal error during installation. .
Final Result: Installation failed with error code: (0x80070643), Fatal error during installation.


Putting that into my IE Url gives me the following

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; Media Center PC 4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)

Im currently using Windows XP Media Center Edition Service Pack 3





Feb 18, 2009 at 6:55 AM
Hmm, this looks like an error installing the .NET Framework 3.5, rather than AddOn Studio. Can you try installing .NET 3.5 by itself from here? If that fails, we at least know what the issue is.

Cheers,
-Dan
Feb 26, 2009 at 4:56 AM
Sorry for the late response. the email notification got sent to my spam box which i never check.

An attempt to download from that link does not work, neither does downloading anything from the site work. ( I tried downloading IE7 as another test, that also failed. )
When i click download it just opens up the normal "Windows cannot display this webpage" error.
Dunno if its related or if it always shows this but at the top of the screen is a blue bar saying "Install Silverlight" but i have already downloaded it several time and the blue abr is always there.
I did this on IE because thats the only browser that can acess the download site is it not?
Could it be some firewall or my Norton Internet Security Blocking it? Or might it be some other wierd problem?
Any help would be appreciated or if its a windows problem and not something you might know exactly how to solve.
Can you direct me to some proper microsoft forums/support for this sort of problem? And possibly what i should ask them?
Feb 27, 2009 at 6:01 PM
Edited Feb 27, 2009 at 6:02 PM
Bizarre, I don't know what the issue could be, you could try temporarily turning off your firewall to see if that fixes it. Otherwise I can't really help you as it's a .NET Framework issue, not AddOn Studio.

I would suggest hitting the .NET Framework Setup Forum at -
http://social.msdn.microsoft.com/forums/en-US/netfxsetup/threads/ 

Under the forum, they have a thread to follow to see what's happenning during setup of your machine as well as a FAQ for common setup issues. If neither of those resolve your issue, I would post a new thread to that forum.

Good luck :)
-Dan