Installation trouble.

Apr 28, 2009 at 1:20 PM
Edited Apr 29, 2009 at 2:01 PM
Hello,

As the title implies I am having difficulties installing this program. As instructed here are the following details:
1) My operating system is Windows XP
2) Via the Add or Remove Programs i have Microsoft .NET Framework 3.5 SP1
3) Installation log:
The following properties have been set:
Property: [AdminUser] = true {boolean}
Property: [ProcessorArchitecture] = Intel {string}
Property: [VersionNT] = 5.1.3 {version}
Running checks for package 'Microsoft Visual Studio 2008 Shell SP1 (Isolated Mode)', phase BuildList
Reading value 'ApplicationId' of registry key 'HKLM\SOFTWARE\Microsoft\VisualStudio\9.0'
Read string value 'VisualStudio'
Setting value 'VisualStudio {string}' for property 'VisualStudio'
The following properties have been set for package 'Microsoft Visual Studio 2008 Shell SP1 (Isolated Mode)':
Property: [VisualStudio] = VisualStudio {string}
Running checks for command 'VSShell90SP1\vs_shell_isolated.enu.exe'
Result of running operator 'ValueEqualTo' on property 'VisualStudio' and value 'VisualStudio': true
Result of checks for command 'VSShell90SP1\vs_shell_isolated.enu.exe' is 'Bypass'
'Microsoft Visual Studio 2008 Shell SP1 (Isolated Mode)' RunCheck result: No Install Needed
Launching Application.
Running command 'C:\WINDOWS\system32\msiexec.exe' with arguments ' -I "C:\Documents and Settings\{Name}\Local Settings\Temp\WowAddonStudio.msi" '
I have Microsoft Visual Basic 2008 Express Edition installed on my computer which I downloaded and installed last year.

My problem is I run the installation of the program it gets to the point of "Extracting schema file from World of Warcraft..." then comes up with the error of "Addon Studio for World of Warcraft Setup Wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again. Click the Finish button to exit the Setup Wizard." This error appears every time. I have the vs_shell_isolated.enu file in the same directory as the setup and the installation bypasses the downloading so it must access the .enu file.

Any help is appreciated as this program seems really promising. Thank you in advance,

Jigsaw.
Coordinator
Apr 29, 2009 at 5:05 PM
The schema it's referring to is the FrameXML schema that we use to validate the FrameXML you write is correct. The installer step here is that it goes the MPQ file (the Warcraft resource file), opens it up and pulls the file out.

This could fail for a couple of reasons

- Security/Permissions - The location of your wow installer - If it's under "Program Files", it may not have security permissions to open the MPQ file. Normally this shouldn't be a problem if Wow is installed under "C:\Users\Public\Games\World of Warcraft" (on Vista) and the installer is run as an administrator
- Not found - The registry key where you installed World of Warcraft is different than the currently installed path, or you renamed the path something like "wowv3" instead of the default title "World of Warcraft"
- Latest Patch update - The latest patch could have changed the location of the schema file in the MPQ or could be causing some other error. We'd have to patch the AOS installer
- Something else entirely - We'd have to patch the AOS installer

If #1 and #2 don't fix your issue, let us know and we'll file a bug.


Thanks,
-Dan
Apr 30, 2009 at 8:07 AM
Edited Apr 30, 2009 at 2:13 PM
Thanks for your reply, Dan.

If I am to try #1 or #2 what would be the best way to do it? I do not really want to install World of Warcraft again in an alternate location because the time it takes is quite long. I am the administrator so #1 may not apply although the location is under "Program Files" however, that location is different to that of the registry key, to my knowledge.

Edit: I decided to check the location of WoW through the Registry Editor, and the location is current. That said it is not the default location, it is inside a file which is in Program Files.

Edit 2: Issue is resolved, thanks very much for your help. For future problems of the same nature I moved the file back to its default file path and the installation worked correctly. Sadly I have gotten the error of no display in the toolbox. I have commented in that and will continue further discussions there.

Thanks,

Jigsaw.
Coordinator
May 1, 2009 at 3:37 PM
You shouldn't have to install Wow again, you simply need to copy/paste it into a location that won't give the security permissions issues. For the files, here's what you would need to do

Remember that you are changing PC settings so backup your machine, backup your registry, and take the necessary precautions.

1. Make sure the Wow directory is "C:\Users\Public\Games\World of Warcraft" (on Vista). If it's not, move it to that location
2. Make sure the directory itself is titled "World of Warcraft" and not "WowV3" or something different
3. Open up regedit.exe to look through your registry. Search for your old path that you changed from step #1 (ex: "Program Files\World of Warcraft"). If you find a registry key that uses it, go ahead and update the old path with the new one from step #1 ("C:\Users\Public\Games\World of Warcraft")
4. Update any desktop/toolbar shortcuts to point to the new location where Wow is installed

I hope this helps,
-Dan
May 3, 2009 at 1:44 AM
That is what I did, moved the directory to Program Files, the default location and the installation worked perfectly. However, I started AddOn Studio when it installed and sadly I have no content in the Toolbox. I hope that error is easy enough to fix, and I've made a comment about it in the Work Issues section under the similar error to mine. I did try reinstalling and repairing like instructed to the other person with the issue, but this did not work.
Coordinator
May 4, 2009 at 6:11 PM
One last thing to try is to try running AddOn Studio as an administrator and see if that's the reason the toolbox items can't load.

Hope this helps
May 5, 2009 at 1:05 PM
Thanks for your help so far Dan,

I opened it as admin and the following error appeared: "Package Load Failure    Package 'Microsoft.WowAddonStudio.Frame.Xml.Editor.FrameXmlEditorPackage, FrameXml.Editor, Version=2.0.40211.1, Culture=neutral, PublicKeyToken=652b006152260a0a' has failed to load properly ( GUID = {<large number>} ). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'appenv /resetskippkgs' to re-engable package loading." If I disable the package the error goes away however I can't access the toolbox, I'm assuming this may be preventing it, and if i restart it has the same error.

Plus, having a look at screenshots I do not see the same view when i open a project. I do not see the blood elf picture as a background and no addon border to start with, all i see is text, and the visual option is checked. Again, maybe this has something to do with the above error.

Thanks,
Jigsaw.
Jul 7, 2009 at 10:02 PM

i am having this same problem, but i'm no wiz with computer stuff.  how do you change the path?