Need help with one some error

Jul 18, 2009 at 3:59 PM

Hi, I need help with one error that I want to fix. When I am trying to start a new project it says:

"'C:\Documents and Settings\(Name)\Local settings\Temp\1fhnyngn.4rq\Temp\(Addon-name).wowproj' cannot be opened because its project type (.wowproj) is not supported by this version of this pplication. To open it, please use a version that supports this typ of project."

I have downloaded right version and got right visual studio. Last time it worked for me was when i tried download Visual Studio 2005 (maybe it was 2003) why i downloaded that was because (i think) of Steam/VALVe is useing 2005 and/or 2003.

If this is the problem, then my question is "how do i fix this?"

Jul 20, 2009 at 6:38 PM

You don't need Visual Studio to use AddOn Studio, unless you want to compile AddOn Studio yourself.

That being said, the problem is likely from an old .wowproj project type. I'd suggest trying to import the selected project. Go to File...Import... and go to the location of your project. If that doesn't work, go to File...New Project... Build a new basic addon, in the Solution Explorer window, delete everything, then right click on the project name, select add existing item... and then re-import the pieces of your old project.

 

Hope this helps,

-Dan

Jul 20, 2009 at 8:34 PM

Hmm... I have tried these two "guides" but nothing works yet. If I try to import this project in File -> Import then nothing... absolutely nothing happens... then i try the other way... I do a new project and go to the Solution explorer and there are no files in. The only thing I see is "'Solution "(Addon name)' (0 projects)". So if I look in the folder where I have the addon it is empty the only thing is in there is only the solution file.

Shall I make some other files and then import?

Jul 20, 2009 at 9:00 PM

Step 1 - Build a new Project - When you open AddOn Stduio, select File...New Project... and select "Basic Warcraft Addon" as shown below

 

 

Step 2 - Add items from Solution Explorer - Next, go to the Solution Explorer for your project, right click on the project name, and select "Add...Existing Item..." as shown below

 

 

Step 3: Add Files - Add the dialog, navigate to the location of your existing addon, and select all the files you want to import as shown below.

 

 

 Note that if you have sub folders, you will have to create the new folders and then do the same step (add existing item...) to add them to the correct subfolder.

Cheers, -Dan

Jul 21, 2009 at 1:02 PM

I am stuck on Step number 2. It is because I do not got this "(Addon name)" file in, and it says this to you: "Solution '(Addon name)' (1 project)" for me it says "Solution '(Addon name)' (0 project)" that is a very big problem! I cant do this step

What shall I now... I have not got some ideas longer

Jul 21, 2009 at 2:44 PM

I don't understand how after step #1 you are getting to an empty solution. In any case, can you right click on the "Solution (Addon name) (0 project)" and select Add...New Project... then start from step #1?

Jul 21, 2009 at 3:34 PM

I didn't said this... every time I try to make an new project, it is coming up an error that says the same thing as the first post... and after that I go to the solution explorer and theres nothing this "Solution" thing is gone too, but if I open it from the folders, then it is coming up, thats a wierd thing.

Now I have tried this too... and this happens same thing

Jul 21, 2009 at 3:44 PM

Sorry, I think I misunderstood your issue to be that you had an existing AddOn Studio project that isn't loading. I now see your issue is that you can't create AddOn Studio projects. My apologies!

 

Here's what I think you need to do.

1. Go to Add/Remove Programs and uninstall AddOn Studio
2. Go to "C:\Program Files\AddOn Studio for World of Warcraft" and ensure that all the directory contents are deleted
3. Download AddOn Studio again from the Download page http://addonstudio.codeplex.com/Release/ProjectReleases.aspx?ReleaseId=22870

Let me know if this fixes the issue

Jul 21, 2009 at 5:11 PM

Okay, it is done and It is same problem

with other words it wont work

Jul 29, 2009 at 2:37 AM

I have the exact same problem.

I am using Windows Vista Home Premium with SP1 and I have Visual Studio 2008 Standard, also with SP1 installed on my machine.

Aug 14, 2009 at 5:19 PM
Edited Aug 14, 2009 at 5:23 PM

I have now found a very interesting thing:

If you open up an solution file, go to "Solution Explorer and right-click on "Solution (name of the solution)" then go to "Properties", isnt it anything in there it is some wrong?? Like in "Debug Source Files" there are 2 locations that doesnt exists first:

"AddOn Studio for World of Warcraft\vc7\atlmfc"

and:

"AddOn Studio for World of Warcraft\vc7\crt"