Can not find WowPath

Nov 6, 2009 at 1:19 AM

During instal I got a pop up saying that it could not find the wow path, I wasnt too concerned as I assumed I could point to it at a later time. However from all the documentation I am finding the issue isn't resovable. When I go into a fresh project, and go to the project properties (as the tutorial describes) I only have 2 tabs. "AddOn Info" and "Files" there is no third "General" tab and I can't seem to find any way to set the path, in turn leaving me unable to build the project.

As a note, I did infact have world of warcraft installed on the host machine at the time of the AddOn studio install. however the game is in my "Public" folder and AddOn Studio is in "Program Files (x86)"

If someone has the answer it would be greatly appreciated.

Thanks, Scott

Jun 21, 2010 at 7:13 AM

i know its a LLOOONNNNGGG time but I'm new to addon studio & i HAD the same problem & justfixed it :)

I did 2 things and not 100% sure which fixed it but its fixed :D

 

1) u need a key named "GamePath" in the registry in "HKEY_LOCAL_MACHINE\SOFTWARE\Blizzard Entertainment\World of Warcraft" having the installation folder of the game

2) run the game in administrator mode (as the GMs say) that should make WoW automatically add required registy keys.

reinstall add-on studio should get u up and running

 

NOTE: i also had a problem where all the frames were kinda empty (just a rectangle) that fixed it too, when u run the add-on the game should start

I hope this helps u or any1 who stumbles upon the same problem :)